Anyone knows anything about the RACE mode?


Hi, so the default Resource, Race. It doesnt work. I tried rewriting the code a bit, but nothing, i cant even get past the loading screen, it stays at Initializing Session, doesnt actually spawn me. Whats with it? If at least i could debug the problem, but i cant even enter the game…


Can you join the server if you leave the gamemode at freeroam?


yes ofc. Freeroam works, now i tried looking at the debug stuff, there are multiple errors in the Race_client. Im gonna try to fix them but im not really familiar with the type of logic this scripted in.


Honestly, i think its not even a proper racemode, just some sort of 10 minutes half completed work. I tried to resolve the errors but you resolve one error, 2 other appears. Things that are used dont even exist anymore like isThisComputerLocalHost() or smth, or “echo” and the list goes on.


Yeah, i wasted another hour trying to figure that shit out, but its nonsense. The only way is writing a custom one. :\


this game mode is for CitizenFX on GTA IV, which hasn’t been supported for a long time now

unsure why it’s still kept in the data repo tbh :confused: